Email request connectivity log showing failed due to "Rate Limited" status and the details are "Error during HTTP request" in JIRA Service Management Cloud
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
When a custom email stops processing emails from the custom mailbox, it is likely due to the email connection. Checking the "Connectivity Log," it shows multiple "Rate Limited" connection statuses and the detail shows "Error during HTTP request."
Environment
JIRA Service Management Cloud
Diagnosis
Go to Project Settings > Email Request
Click View Log for the impacted email
Click Connectivity Log and it will show as per the screenshot:

Cause
The email processor will try to pull messages from your mail server every minute, so even though it fails, it will likely connect on the next try. When the connection between Jira and the mail server fails many times, Jira no longer tries for a certain amount of time, and this time increases if it fails again. Hence you notice multiple error logs mentioning "Retrying in xxx minutes."
This usually happens because the custom email uses Basic Authentication, and the connection will fail when the password is reset or expired.
Solution
Get a screenshot of the connectivity logs. This will be handy if you want to track when the email starts failing.
Click on the three dots on the upper right hand side and select "Disable all email requests"
OR you can choose the custom mail handler and Remove it
A pop-up will show up like below, click on Turn Off
Then Turn on email support:
Then, click on Turn on and, Add External mail
Select the "Microsoft" or "Google" option to reconnect it using OAuth. For more information about this, refer to Switch your Microsoft and Google email accounts to OAuth documentation
Once reconnect, monitor the email connectivity and processing logs.
OR
Go to Settings > Products > email request
Select the mailbox from the Email requests
Click on the three dots > Delete
https://<Your_intsance>/jira/settings/products/jira-service-management-email-requests
Reconnect from your project email request using Add External email
To reprocess the old email in the inbox that was missed, reach out to support
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