Deleting priority returns 504 Gateway timeout
Platform Notice: Data Center Only - This article only applies to Atlassian apps on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When trying to delete a priority having ~65k issues assigned to it this might fail with a 504 Gateway Timeout.
Cause
Due to the large number of tickets assigned to that priority, the request will get aborted after some time and the deletion process will fail. This problem is being tracked in our public-facing issue tracker so make sure to add yourself as a watcher to receive further updates.
Solution
Your team can use our public APIs to overcome the timeout issues we are receiving in UI. Right below follows a sample in cURL that can be used by your team to delete the desired priority.
Delete priority using cURL
curl --request DELETE \
--url 'https://your-domain.atlassian.net/rest/api/3/priority/{id}?replaceWith={replaceWithNewPriorityID}' \
--user 'email@example.com:<api_token>'For more details about this API parameters and even to have access to snippets in other languages, please take a look at the following link:
⚠️ The above API is experimental and is going to be updated soon, so pay attention to this changelog.
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