CSV import fails with the error: The specified author is not a user

Platform Notice: Cloud Only - This article only applies to Atlassian apps on the cloud platform.

Summary

CSV import fails with an error "Issue can't be created due to the error/s [ The specified author is not a user.; The user 'so-and-so-user' does not exist ]"

Cause

Jira does not allow user name mapping anymore because there can be two users with the same name so to avoid confusion, we now use only AAID(Atlassian Account ID) or email address for mapping.

Solution

  • In the import CSV file, if you have different columns for the assignee, reporter, and author with usernames then remove those columns and only have the column for assigneeID, reporterID and authorID with the actual users' email address or their AAID(Atlassian Account ID).

  • In the field mapping screen, you must map assigneeID with Assignee and ReporterID with Reporter accordingly.

Updated on September 25, 2025

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