Confluence Page Gadget does not load the content for some users
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
On Jira, user couldn't see the content in the Confluence Page Gadget but only the message saying "Please login OR contact Administrator to configure Application Link"

Environment
Any supported version of Jira integrated with Confluence
Diagnosis
This is only affecting some users
Affected users are already logged in to Jira
Application link between Jira and Confluence is working fine
The affected users couldn't view the Confluence page on Confluence
Cause
The affected user(s) do not have the permission to view the Confluence page
Solution
Grant the affected user the permission to view the Confluence page if the user is expected to be able to view the page. Otherwise, configure the Jira dashboard or the Confluence Page Gadget to show the right content to the right users
Was this helpful?