Can't add organization to request with error "We couldn't submit your request"

Platform Notice: Cloud Only - This article only applies to Atlassian apps on the cloud platform.

Summary

When a customer tries to add an organization to their request using the Share button via portal, they get the error message: We couldn't submit your request. Refresh the page and try again.

Diagnosis

Find the error in your browser's devtools

  1. Check the Network logs using your browser's Developer Tools,

  2. In the Network tab, look for the action of attempting to add the Organization to the request using the Share button

  3. You should find a PUT request that errors with the 400 HTTP status code to the endpoint https://[INSTANCE-NAME].atlassian.net/rest/servicedesk/1/customer/participants/[WORK-ITEM-KEY]/add

  4. The Response tab for this call shows:

{ "errors": [ { "errorMessage": "An error occurred while validating organisations" } ], "reasonKey": "sd.customer.organisations.custom.field.validate.failed", "reasonCode": "400" }

Cause

Lack of permissions from the customer or organization

There is a problem with the customer permissions or the organization is not part of the project.

Solution

Check the project's configuration

As a project administrator:

  1. Make sure that the Organization the customer wants to add is added at the project level.

  2. Make sure that the customer facing the issue is part of the Organization they want to share the request with.

  3. Make sure that at the project level the Service Project Customer - Portal Access role has Edit Issues permission under the Project permissions page. 

If after checking the points above you are still experiencing issues, contact the Atlassian support team for further investigation.

Updated on September 26, 2025

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