Blank space in email sent via Jira Automation while using tables in issue description
Platform Notice: Cloud Only - This article only applies to Atlassian apps on the cloud platform.
Summary
The work item description is not displayed in the expected table format in an email sent via Automation.
Environment
Jira Cloud
Diagnosis
Create a work item with a table format in the description.
Run an automation that sends an email with the description of the work item.
Upon receiving the email, we can observe that the table format is missing, and the email displays the table in plain text with raw formatting.
Cause
The smart value (workitem.description.html) was used in automations to resolve the above formatting issue. However, this introduced unneeded blank spaces in the emails.
It seems the extra space depends on the renderer, as we can see very little space in web-based Gmail compared to an Outlook client.
Solution
Go to Automation > Send Email.
Select More Options to expand it.
Uncheck the box Convert line breaks to HTML line breaks.
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