Attaching a File Results in Request Entity Too Large

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Attempting to attach a file results in:

(Auto-migrated image: description temporarily unavailable)

HTTP logs contain:

1 HTTP/1.1 413 Request Entity Too Large

Diagnosis

System is behind some sort of proxy, firewall or network security

Cause

The network security/proxy has a limitation on request size

NGINX USERS: If you have not specified a size limitation, NGINX will set client_max_body_size to a default of 1MB. See http://nginx.org/en/docs/http/ngx_http_core_module.html#client_max_body_size.

Resolution

Increase the allowed request body limit for the proxy. For example:

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.