Apache Tomcat shuts down immediately after starting due to port bind on 8005

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When trying to start Jira using the Jira service or the start-jira.bat the tomcat immediately shutdowns with an error

1 java.net.BindException: Address already in use: JVM_Bind

Environment

  • Jira Software 8.x / Jira Service Management 4.x or above

Diagnosis

On Linux, check Jira-Install-dir/log/catlina.out log.

On Windows check  Jira-Install-dir\jira-{version}-stdout(or stderr).{date}.log

Cause

After the application of some recent Windows Patch, It is observed that it was SCCM software Update Express (CcmExec process) or some other services which were using the Tomcat port 8005 and the port was set to 8005 by default, which may cause port binding errors.

Solution

  • To determine the owner of port 8005, run netstat -abno using the command prompt.

  • Modify the tomcat shutdown port to any other port in the server.xml file which is under <Jira-Install-dir>/conf/server.xml

  • Under <Jira-home-dir> remove the .jira-home.lock

  • Restart Jira.

Updated on March 12, 2025

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