Activity stream is empty when filtered by username
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Symptoms
When using "Global filter" on Activity Stream and filtering by a username, no results are being displayed. There are no errors in the logs.
Environment
Jira Data Center on any version
Diagnosis
Check the username for the user, if the username is in mixed case or contains an underscore (e.g.: "john_doe"), then this KB article is for you.
Cause
JIRA has problems with usernames with mixed cases and underscores. This is the root cause of the problem here. You might want to try to reproduce this problem with a username with all lowercases to confirm this.
Solution
Resolution
If you are not using Delegated Authentication method :
You need to change the username in the LDAP or Crowd and then synchronize the directory in JIRA so that the username becomes lowercase.
If you are using Delegated Authentication method :
Since there is no synchronization in Delegated LDAP directories, you would need to hack the database to make the changes in the database. Please contact Support for this.
As a long term solution, I would suggest using Crowd in between JIRA and LDAP. Crowd has a built in functionality to handle the case related problems with username. You might be interested to review Case Sensitivity of Usernames and Groups with regards to this topic.
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