502 Proxy Error received when accessing the Applications Page
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When accessing the Applications page on the Jira Administration it fails with the error
502 Proxy Error
The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /plugins/servlet/applications/versions-licenses.
Reason: Error reading from remote server
Diagnosis
1. Reproduce the issue while collecting a network trace:
Go to ⚙️ → System → Logging and profiling.
Click at the Configure logging level for another package
Add the package org.apache.http with the DEBUG value
2. Review the debug to identify the error occurring for the connection with the MarketPlace:
1
2
3
4
2021-11-22 11:25:05,609 http-nio-8080-exec-2 DEBUG xxxxxx 684x361049x1 zbz90b /plugins/servlet/applications/versions-licenses
[o.a.h.conn.ssl.SSLConnectionSocketFactory] Connecting socket to marketplace.atlassian.com/104.192.142.6:443 with timeout 15000
2021-11-22 11:25:20,620 http-nio-8080-exec-2 DEBUG xxxxxx 684x361049x1 zbz90b /plugins/servlet/applications/versions-licenses
[o.a.h.impl.conn.DefaultHttpClientConnectionOperator] Connect to marketplace.atlassian.com/104.192.142.6:443 timed out. Connection will be retried using another IP address
Cause
When accessing the Applications Page, Jira will check the versions and licenses applied, reaching the MarketPlace site.
This error occurs when the Marketplace can't be reached.
Solution
From the top navigation bar in your application, choose > Add-ons or Manage apps
Click the Settings link at the bottom of the page.
Uncheck the Connect to the Atlassian Marketplace checkbox. This option is enabled by default.
Click Apply.
The change will take effect immediately.
Reference:Switching UPM to offline mode
You can confirm that MarketPlace access was disabled reviewing a support.zip:
Application.xml will contain:
1
<com.atlassian.upm.SysPersisted-properties-upm.pac.disable>true</com.atlassian.upm.SysPersisted-properties-upm.pac.disable>
Atlassian-jira.log and Catalina.out:
1
com.atlassian.upm.SysPersisted:properties:upm.pac.disable : true
Was this helpful?