Insight ServiceNow integration imports does not import all the asset of each table at once.

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Insight ServiceNow integration only imports partial information, for example: Computers, Servers, Business Services;

While the ServiceNow instance has thousands of these (e.g. ~3000+) - the Integration imports less (e.g. 1756), and the numbers seem to vary with each import.

Environment

Insight ServiceNow integration 1.2.2

Diagnosis

  • Configuring the Insight ServiceNow integration, with Admin credentials, creating a Predefined Structure and configuration, will not sync the full scope of available assets in various tables.

  • Testing with ServiceNow Table REST APIs to get the same (e.g. using Postman) returns different results than Insight, and again, not the full scope of assets.

Cause

The REST API timeout in Servicenow is set by default to 60 seconds. If the datasest to import is large, the instance will timeout before the import was completed.

Solution

  • Possibly, if you run the import a few times, each run may add some objects.

  • Increase the REST API Timeout (e.g. 1-5 minutes trial and error) to allow Insight to get all the data at once.

Updated on February 25, 2025

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