How to set default sharing for filters and dashboards from private to public
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
This article will show how to set default sharing for filters and dashboards from private to public
Environment
Jira Server/Data Center
Diagnosis
Changing the Default sharing for filters and dashboards from private to public doesn't seem to take effect
Cause
Setting Default sharing for filters and dashboards from private to public only adds the option to the users but doesn't automatically enable the feature. Users must navigate to their own user profile preferences to enable this feature in their profile.
Solution
Log in as a user with the Administer Jira global permission.
Choose > System > Default user preferences to open the User Default Settings page.
Click the Edit default values button. The User Default Settings window displays.
Make the changes you wish to apply, in this case set the Default Access for filters and dashboards to public.
Click the Update button. Your changes have been applied.
Now go to your User Profile by clicking on your avatar and selecting Profile
Go to the Summary tab
Under your user profile preferences, a new option appears, “Filter and Dashboard Sharing,” where you can opt into this and change it from private to shared.
Once both of these are in place, then newly created filters (of yourself) will default to shared with logged-in users.
Each existing user will have to follow steps 4 to 9 to opt into this setting.
Was this helpful?