How to change Indexing Limit Safeguards in Jira
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Jira is equipped with safe guards to help prevent unexpected issues from occurring. These limits, however, aren't always tuned appropriate for your specific environment and they might need to be modified in order to ensure optimal results. Additional information about these safe guards and why they are in place is available in the articles below:
Some of these safeguards can be added directly from Settings > System page, however, others must be set as a JVM variable during startup
Environment
>=8.20.12
Diagnosis
If the safe guard you need to change is not available from Settings > System > General Configuration > Advanced Settings, then you will need to add the value as a JVM argument, then restart Jira
Cause
Jira is equipped with many safe guards and not all of them are noted at Settings > System > General Configuration > Advanced Settings.
Solution
To add the parameters, below JVM arguments will need to be added to JVM configuration. The exact way it's done will depend on how Jira was installed initially.
For standalone Jira's (i.e. if Jira was installed on a physical or virtual server via installer or manual method):
Navigate to JIRA_INSTALL/bin
Edit the setenv file (.bat for windows, .sh for linux)
Change JVM_SUPPORT_RECOMMENDED_ARGS="" to JVM_SUPPORT_RECOMMENDED_ARGS="-Djira.safeguards.indexing.issue.worklogs=5000" , for example, reference the screenshot below. Please note that the 5000 is an example value.
Restart Jira
For Jira deployed by using AWS quick-start templates, the same JVM argument will need to be added to CATALINA_OPTS parameter of the respective .yaml files.
Please see below linked KB for further details: https://confluence.atlassian.com/enterprise/deploy-data-center-products-with-the-aws-quick-start-template-1224641863.html
Likewise, for K8 and docker based installations, please refer to the below guide: https://hub.docker.com/r/atlassian/jira-software
After the restart, please confirm that the changes took effect by searching the startup logs (atlassian-jira.log or catalina.out, with later though - please be aware of the following KB if Jira runs in Docker: https://confluence.atlassian.com/jirakb/jira-running-as-a-foreground-linux-service-prevents-catalina-logs-to-be-created-1072474677.html)
% grep 'safeguard' logs/catalina.out
jira.safeguards.indexing.issue.worklogs : 5000
jira.safeguards.config.restricted.groups :
jira.safeguards.issue.comments : 1000
Was this helpful?