Clicking on "Add comment" in a Jira Service Management issue redirects to a new page

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When clicking on "Add comment" in a Jira Service Management issue, instead of opening a comment box on the same page, users are redirected to a new page without the details of the issue.

Environment

Jira Service Management 5.0.0+ 

Cause 1

A Jira Service Management version affected by the following bug is being used: JSDSERVER-11937

Cause 2

The service-desk-comment-field module from Jira Service Management is disabled.

Solution

Solution 1

Update Jira Service Management to any version that contains the fix for JSDSERVER-11937

Solution 2

Enable the service-desk-comment-field module with the following steps:

  1. Go to Administration (⚙ icon) > Manage apps, then click on "Manage apps" again in the left menu

  2. Select "All apps" in the app filter, then search for "Jira Service Management."

  3. Click on it to expand its details, then click on '+' to expand its list of modules

  4. Search for service-desk-comment-field. If this module is disabled, click on "Enable."

Updated on February 28, 2025

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