Assets Discovery scan is stuck

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Assets Discovery scan stops working. In the Assets Discovery logs, the following DEBUG message is shown.

1 22.04.2024 16:46:33: [Debug] Start initializing of Asset Scanner

Environment

Assets Discovery

Diagnosis

The Discovery log when set to DEBUG, is stuck at below log line suggesting that the scan is being initialized but nothing further happens.

1 22.04.2024 16:46:33: [Debug] Start initializing of Asset Scanner

Cause

The AssetHistory.dat file in the Discovery folder is corrupted and has 0 KB Size.

The precise root cause of this issue is presently unidentified. However, in specific cases, it has been observed that the problem may occur due to an abrupt shutdown of the Host where Discovery is installed, while the Discovery scan is still active and scanning the asset objects.

Solution

  1. Stop the Discovery service.

  2. Remove the AssetHistory.datfile from the Discovery folder.

  3. Start the Discovery service again and launch a scan that failed previously or wait for the next scheduled scan.

Updated on February 24, 2025

Still need help?

The Atlassian Community is here for you.