Active Directory or LDAP sync is not creating new users or providing access

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Newly created LDAP users are not added to Jira or given access to log on after the directory is synced to Jira.

Environment

Jira is connected to Microsoft Active Directory.

Diagnosis

  • The users exist in the directory being synced.

  • The Active Directory test connection is successful.

  • The directory sync completes successfully with no errors and the following entry in the <jira-home>/log/atlassian-jira.log:

1 [c.a.crowd.directory.DbCachingRemoteDirectory] FULL synchronisation complete for directory

The following KB articles do not apply to the situation:

Cause

The newly created users in AD are missing the required fields to be imported into Jira.

Solution

Make sure that the newly created users have values for all of the attributes configured on the Jira Directory integration at the Active Directory server, and perform a full sync in Jira.

Updated on February 25, 2025

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