"Specify the Priority in string format" error during sync from Jira Align

Summary

During a sync from Jira Align to Jira, the connector fails to sync, and the audit log shows the following error message:

"priority":"Specify the Priority (name) in the string format"

Cause

The Jira priority value provided in Settings > Jira Settings > Field Management (tab) > Priority > More actions (...) > Edit Mapping does not match any of the Priority options on Jira. This can occur if:

  • There was a typo during the configuration. The Jira priority values input must exactly match the corresponding priority option on Jira. Any slight differences, such as “medium” instead of “Medium,” will result in sync failure.

  • The Jira Align Super Admin performing the configuration uses a language option different from the default language of the Jira instance. Therefore, the Priority options on Jira are translated into the user's language choice. If the connector priority mapping is done with the user's language values, it will not match the actual Priority option values on Jira.

Solution

To avoid typos or language difference errors, the exact Priority options Jira will accept from the Jira Connector can be determined from the Jira Align API.

Query priority options from REST API

  1. Make a Jira Align REST API call on the Connectors endpoint to retrieve the Priority options.

    • GET /align/api/2/Connectors/{connectorId}/priorities

  2. Go to Settings > Jira Settings > Field Management (tab) > Priority > More actions (...) > Edit Mapping.

  3. Make the desired mappings by using the exact jiraPriorityName value from the API response for the Jira priority values.

  4. Save.

Updated on November 21, 2025

Still need help?

The Atlassian Community is here for you.