特定のステータスからケースをトランジションまたはクローズした際に解決状況フィールドを更新できない
プラットフォームについて: Data Center のみ。 - This article only applies to Atlassian apps on the Data Center プラットフォーム。
この KB は Data Center バージョンの製品用に作成されています。Data Center 固有ではない機能の Data Center KB は、製品のサーバー バージョンでも動作する可能性はありますが、テストは行われていません。 Server* 製品のサポートは 2024 年 2 月 15 日に終了しました。Server 製品を実行している場合は、 アトラシアン Server サポート終了 のお知らせにアクセスして、移行オプションを確認してください。
*Fisheye および Crucible は除く
要約
課題を解決しようとした際に、解決のオプションが表示されないため、解決状況フィールドに入力できません。
環境
Jira Software v8.x 以降。
診断
課題フィールドを更新するための事後操作が設定されているかどうかを確認する必要があります。

影響を受けるトランジション (たとえば、「進行中」から「クローズ」まで) 専用に新しいトランジション ID が作成されているかどうかを確認します。
次の例では、トランジション「クローズ (81)」が「進行中の作業」にマッピングされていることがわかります。
他のステータスには、トランジション「完了とマーク (61)」がマップされています。

原因
一意の ID を持つ複数のトランジションが、特定の状態のトランジション間でマッピングされています。
ソリューション
解決策 1:
トランジション「クローズ (81)」を削除し、影響を受けるステータスに「完了とマーク (61)」トランジションを再利用します。


解決策 2:
「進行中の作業」から「クローズ」までの「クローズ」トランジションを選択します。影響を受けるプロジェクトの解決済み画面としてトランジション ビュー画面を選択します。


この内容はお役に立ちましたか?