Troubleshoot connections between Bitbucket Cloud and Jira Software
Platform Notice: Cloud - This article applies to Atlassian products on the cloud platform.
- Summary
- This page describes how you can identify and correct connection errors between Bitbucket Cloud and Jira Cloud. If you want to set up a new connection, see Connect Bitbucket Cloud to Jira Cloud. This page covers the following error scenarios:
- Environment
- Any Jira Cloud instance that connects to Bitbucket Cloud. Please see Integrate with Jira Software Cloud using OAuth if connecting to Bitbucket Data Center to Jira Cloud.
- Diagnosis and Cause
- Webhooks not installed
- Diagnosis
- We couldn't add a post-commit hook while connecting with the Jira app.
- Solution
- Read more about webhooks in Bitbucket Cloud.
Possible causes | Actions you can take |
---|---|
You don't have admin permissions on the Bitbucket Cloud repo | Talk to a Bitbucket Cloud admin. They can use the URL from the warning dialog to add the webhook manually. Talk to your workspace admin to get admin permissions on the repo. |
- OAuth error
- Diagnosis
- INVALID CREDENTIALS
- Solution
- We couldn't refresh the account when you clicked Refresh Account because the OAuth credentials were incorrect or no longer exist.
Possible causes | Actions you can take |
---|---|
OAuth credentials were deleted or changed in Bitbucket Cloud OAuth credentials were changed in the Jira app, using incorrect details | Recreate the OAuth token in Bitbucket Cloud. Re-enter the OAuth credentials in the Jira app. |
Scopes were changed in Bitbucket Cloud | Check that the OAuth credential scopes in Bitbucket Cloud are correct. |
If the actions above fail to solve the problem, you can recreate the account. |
- Refresh failed
- Diagnosis
- We couldn't refresh the account when you clicked Refresh Account.
- Solution
Possible causes | Actions you can take |
---|---|
Bitbucket Cloud is unavailable | Try again later. |
Your Bitbucket Cloud or GitHub account has been disabled | Contact Atlassian Support. |
If connecting Jira Cloud to GitHub, your account has been disabled. | Contact GitHub support. |
- Sync error
- Diagnosis
- We couldn't sync the repository when you clicked Sync repo.
- Solution
Possible causes | Actions you can take |
---|---|
The Atlassian account or workspace has been renamed The repo has been deleted, renamed, or moved The repo slug has been changed OAuth credentials were deleted in Bitbucket Cloud | If the repo has been deleted in Bitbucket Cloud, you'll need to delete the repository from the list. If the repo has been changed in Bitbucket Cloud, then delete the repo from the list and then re-add it. |
Your Bitbucket Cloud account has been disabled | Contact Atlassian Support. |
If connecting Jira Cloud to GitHub, your account has been disabled. | Contact GitHub support. |
- Connection is not fully completed
- Diagnosis
- We couldn't add a post-commit hook while connecting with the Jira app. Read more about webhooks in Bitbucket Cloud.
- Solution
Possible causes | Actions you can take |
---|---|
You don't have admin permissions on the Bitbucket Cloud repo | Talk to a Bitbucket Cloud admin. They can use the URL from the warning dialog to add the webhook manually. Talk to the workspace admin to get admin permissions on the repo. |
- Issue links take me to Jira unexpectedly
- Diagnosis
- When Jira Software Cloud is connected with Bitbucket Cloud, clicking an issue link in Bitbucket takes you to Jira when you were actually expecting to see key details of the issue displayed in a dialog in Bitbucket.
- Solution
Possible causes | Actions you can take |
---|---|
Your connection between Jira Software Cloud and Bitbucket Cloud still uses the legacy connector. | An admin on both the Jira Software and Bitbucket accounts can reconnect Jira and Bitbucket from the 'DVCS accounts' screen: From the Jira Software dashboard, select the cog (settings) icon and select Applications. Note: This will simply re-connect Jira Software and Bitbucket – it won't cause any data to be lost. |