No mail notifications are received for Crucible review activities
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
No mail notifications are received by Crucible reviewers when changes are made to the Crucible reviews.
Environment
Crucible 4.x
Diagnosis
1
2
com.sun.mail.smtp.SMTPSendFailedException: 554 5.2.252 SendAsDenied; crucible@atlassian.com not allowed to send as sam.k@atlassian.com
com.sun.mail.smtp.SMTPSendFailedException: 554 5.2.252 SendAsDenied; crucible@atlassian.com not allowed to send as sk@atlassian.com
In SMTP Config, under Required settings, the option selected for Send emails from is set to the User address.
Cause
In Fisheye/Crucible the Mail Server settings its configured to Send Emails from the User address however, the Office 365 mail server is rejecting being able to send email from Fisheye/Crucible as the specific user.
The Office 365 Mail server doesn't allow Send email on behalf of another user and must be enabled on the Office 365 Mail server in order to allow the mails to be sent as instructed here.
Solution
Switch to Send Emails from the Server address option so the Fisheye/Crucible always tries to send the notifications from the email configured on the Fisheye Mail server settings
If you would prefer to use Send Emails from the User address on Fisheye/Crucible, you can then enable the option Send email on behalf of another user on the Office 365 mail server as instructed here for all the users after consulting with your Network Security Team.
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