During Startup: 'Name or service not known' Error Captured In The Logs

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

The following appears in the atlassian-fisheye.log:

1 2 2014-07-20 22:15:43,525 WARN [qtp857222296-139 ] org.eclipse.jetty.servlet.ServletHandler ServletHandler-doHandle - /admin/appTrustCertificate java.lang.RuntimeException: java.net.UnknownHostException: <hostname>: <hostname>: Name or service not known

Cause

The local hostname or the computer name that is running Fisheye is not in the host file or is not resolvable via DNS lookup.

Resolution

Change the local hostname or computer name that is running Fisheye to match the host file, or enter the local hostname into the hosts file if it's not defined previously.

windows

C:\Windows\System32\drivers\etc\hosts

linux/unix environments

/etc/hosts

Updated on April 8, 2025

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