Error while trying to retrieve the supplied base URL
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Symptoms
During Crowd installation the following error prevents you from completing the setup wizard:

Diagnosis
Make sure that the URL entered into the Base URL field is a valid URL that gets you to Crowd. If it is, and the problem persists, please proceed with the following step:
Login to the Crowd Server's OS (if it is on Linux, open a SSH session into the server), and ping the domain in the URL. Example:
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$ ping example23.com
If you get no replies from the ping, proceed with the resolution below
Cause
Most of the time, this is caused by the fact that the Crowd Server itself, is unable to reach Crowd at the provided URL (i.e. the URL is only reachable from external users outside of the intranet, or when a proxy is used).
In this case, the Crowd Server is unaware that the domain is actually itself, with the IP of 127.0.0.1 . It is unable to resolve that domain to the IP of 127.0.0.1
Solution
Resolution
Add the following to the Crowd server's
/etc/hosts
(Linux), orC:\Windows\system32\drivers\etc\hosts
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127.0.0.1 <domain>
Replace <domain> with the provided URL's domain
Example:
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127.0.0.1 example23.com
After that, restart the entire Crowd server's OS, and try to restart the setup again.
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