Crowd 6.x does not start with Java 8 and 11

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Crowd 6.x failed to start up.

Environment

Crowd datacenter 

Diagnosis

  • The application log (atlassian-crowd.log) from the Crowd does not contain any startup information as shown below: 

    atlassian-crowd.log

    1 2 3 4 2024-08-01 16:44:08,936 main INFO [com.atlassian.crowd.startup] Starting Crowd Server, Version: 6.0.0 (Build:#2091 - 2024-07-03) in Data Center mode 2024-08-01 16:44:08,938 main INFO [crowd.console.listener.StartupListener] Joined a cluster with nodes: 1 2024-08-01 16:44:08,938 main INFO [crowd.console.listener.StartupListener] 1. 480e3c3e-fbad-43c2-ae6c-8f96a76fdb6e ...
  • The Tomcat log (catalina.out) indicates that the startup failed

    catalina.out

    1 2 01-Aug-2024 11:05:50.719 SEVERE [main] org.apache.catalina.core.StandardContext.startInternal One or more listeners failed to start. Full details will be found in the appropriate container log file 01-Aug-2024 11:05:50.724 SEVERE [main] org.apache.catalina.core.StandardContext.startInternal Context [/crowd] startup failed due to previous errors
  • Access from Crowd baseURL results in a HTTP 404 error with the message "The requested resource /[/crowd] is not available."

Cause

As previously mentioned in our End of support announcements, Java 8 and 11 are no longer supported with Crowd 6.x.

Crowd 6.x won't start if you use Java 8 or 11.  Please refer to Preparing for Crowd 6.0 for more information.

Solution

Crowd 6.x will support Java 17.

To fix this problem, follow the below KBs:

If you have any issues or questions, please contact Atlassian support.

Updated on March 13, 2025

Still need help?

The Atlassian Community is here for you.