Unable to manage Add-ons because of Tomcat

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

The following appears when you click manage add-ons:

1 2 Caused by: Java.lang. NoClassDefFoundError: com/atlassian/oauth/util/RequestAnnotations at coms.atlassian.sal.confluence.websudo.ConfluenceWebsudoManager.canExecuteRequest(confluencewebsudomanager:java:45)

Diagnosis

It happens when you are using Tomcat 7.

Cause

Tomcat 7 is not stable in Confluence 5.5 prior to 5.5.3.

Solution

Resolution

  • Downgrade your Tomcat to a supported version such as Tomcat 6. After downgrading Tomcat, Confluence User Directories link should appear within the Confluence admin panel.

    To downgrade Tomcat:

    1. Shutdown Confluence

    2. Download a compatible version of Tomcat and unzip it

    3. Copy the bin and lib folder from the unzipped folder into the <confluence install directory>

    4. Agree to overwriting all duplicate files

    5. Start Confluence

Updated on April 2, 2025

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