The version of Team Calendars Plugin installed isn't valid for your license
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Problem
Receiving the following error message after upgrading Team Calendar:

The version of Team Calendars Plugin installed (<version>) isn't valid for your license
Diagnosis
Check if an expired license is being used for the Team Calendars for Confluence plugin.
Cause
The Team Calendar license's expiry date is dated before the Team Calendars plugin release date. For example:
Team Calendars for Confluence license has an expiry date of 2nd June 2015
Team Calendars for Confluence version installed has a release date of 3rd June 2015
Solution
Workaround
Use Team Calendars for Confluence evaluation license.
Resolution
Resolution 1
Renew Team Calendars for Confluence license.
Resolution 2
Downgrade the Team Calendar plugin to a version that was released before the expiry date of the current Team Calendar license:
Verify Team Calendar version release dates
Uninstall the current Team Calendar version by navigating to Confluence admin >> Manage Add-ons >> Uninstall Team Calendar
Install the desired Team Calendar version manually by using the downloaded .obr file obtained in Step 1
To upload an add-on:
From the application's administration console, click the Manage add-ons link.
Click the Upload add-on link at the top right side of the page.
The following dialog appears.
Enter the location of the JAR or OBR file to upload using the file chooser or by specifying a network location by entering a URL.
Click Upload.
A confirmation message appears when the add-on is successfully installed.
If prompted, restart your application to have your change take effect.
If you still see the error message, please clear the plugin cache by referring to the link - How to clear the apps (plugins) cache in Confluence Data Center
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