Seeing Inverted Question Marks with Oracle

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

  1. Random inverted question marks appear replacing quotation marks/hyphens copied from a Microsoft Windows document. For example:

    1 Jeremy¿s going to buy me a surprise gift and I¿m going to act surprised.
  2. Using Oracle with non UTF8 encoding, eg. WE8ISO8859P1 ISO 8859-1 West European

  3. No error recorded in the log file

Diagnosis

Failed the Database Round-trip test in the Troubleshooting Character Encodings. Also you can execute this query to check which is the current database character set:

1 select value from nls_database_parameters where parameter='NLS_CHARACTERSET';

Cause

Some of the characters used by Windows are not covered by the database encoding (eg. WE8ISO8859P1).

Solution

Resolution

Switch to an Oracle encoding that supports Windows characters. eg. AL32UTF8 (Confluence 5.5 or later versions) or WE8MSWIN1252 (Confluence 5.4 or earlier versions).

Updated on April 2, 2025

Still need help?

The Atlassian Community is here for you.