Resolving "Approval required" message when connecting OneDrive to Confluence Cloud

Platform Notice: Cloud Only - This article only applies to Atlassian apps on the cloud platform.

Summary

This articles covers why users may receive "Approval required" message when connecting OneDrive in Confluence Cloud and how to resolve it.

Diagnosis

Verify that this impacts you

  • When attempting to connect OneDrive in Confluence Cloud, user receives "Approval Required" message.

  • User is part of Microsoft or Entra ID managed tenant.

  • Attempt to use the OneDrive import feature.

Cause

The Entra admin has not granted permission for the OneDrive application.

Solution

Grant OneDrive permission

In Microsoft Entra admin portal:

  • Navigate to Manage > Properties

  • Approve application

Alternatively, the admin can pre-approve the application to avoid "Approval required" messages in the future.

Resource: Need admin approval while authorizing

Updated on October 28, 2025

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