Recent Activity section of Content Indexing Admin page and reindexing Audit logs are not updated when Confluence language is set to non-English

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

The Recent Activity section of the Content Indexing page is not updated when the Confluence language is set to non-English languages (like Deutsch, Suomi, etc.)., and the audit logs pertaining to reindexing are not updated. 

Environment

Confluence 8.4+

Diagnosis

After rebuilding the index from the Content Indexing page, the Recent Activity section is blank. 

Upon checking the Audit logs, events pertaining to the reindex are not captured. However, the actual reindex process is successful which can be verified from the logs.

Cause

This behaviour is caused when Confluence language is not English. Updates to the Indexing Recent Activity and reindexing audit logs don't occur.  This is a knownbug and can be tracked below: 

Solution

The workaround available currently is to select English as the Confluence language.

Updated on March 6, 2025

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