Plugins Malfunctioning When Installed by Saving Them in The Confluence Installation Directory
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
Plugins installed from /WEB-INF/lib
appear different or malfunctioning in comparison to the same plugin that is installed from the plugin repository or plugin manager.
Cause
Installing plugins from /WEB-INF/lib
is an old plugin installation technique in Confluence. This is no longer a supported way to install plugins in Confluence.
Resolution
Install plugins from Confluence administration console, via plugins manager or plugins repository.
Was this helpful?