Personal spaces are no longer linked and creator is anonymous
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Problem
The user is unable to access their personal space via User Interface under the top right drop-down menu. They only see the Add Personal Space option.
Symptoms
Personal space links missing after a Confluence upgrade.
Personal space still exists if accessed directly using the URL.
The creator of the personal space is Anonymous
Diagnosis
Run this SQL query to check the CREATOR of the space. If it's NULL, then proceed to the solution below.
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select * from SPACES WHERE SPACETYPE='personal'
Cause
During the upgrade, for some unknown cause, all the personal space creator has changed to NULL causing the creator to be anonymous.
Solution
Resolution
Always back up your data before making any database modifications. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.
Also backup the Confluence Home directory before proceeding.
Run the query below and it will restore all the personal spaces to the original creator.
MySQL :
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update spaces set creator = (select user_key from user_mapping where concat('~', username) = spacekey) where spacetype = 'personal' and creator is null;
PostgreSQL
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update spaces set creator = (select user_key from user_mapping where spacekey = '~' || username) where spacetype = 'personal' and creator is null;
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