Pages Not Showing in Page Hierarchy after Space Import to New Confluence Installation

Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

  1. Import space xml backup from a Confluence instance into a fresh install of Confluence reveals that some pages do not showing up in page hierarchy.

  2. Copy relative path from original instance and paste into new instance reveals that the pages exist, but they are not visible via page hierarchy. (must be logged in as confluence-administrator user in order to perform this step due to restrictions on pages)

Diagnosis

Copy relative path from original instance and paste into new instance reveals that the pages exist, but they are not visible via page hierarchy. (must be logged in as confluence-administrator user in order to perform this step due to restrictions on pages)

Cause

  • New installation does not contain users/groups of original instance.

  • Pages in space export from original instance have restrictions to specific groups that do not exist in the new instance.

Solution

Resolution

  1. Go to space admin for the imported space

  2. Remove the restrictions for all pages

  3. Alternatively, you can add the groups to this Confluence instance as they existed in the original, and add users who need to view those pages to the related groups.

Updated on April 2, 2025

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