Page Properties Report macro doesn't display any content

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

The Page Properties Report macro displays a table containing all the pages that contain the Page Properties macro and labels that must be specified in the Page Properties Report configuration.

However, when there's an indexing problem in the Confluence Instance, the Page Properties Report macro will not be able to display any new content from the Page Properties.

Environment

  • Confluence Server, regardless of the version.

  • Confluence Data Center, regardless of the version.

Diagnosis

  • Newly created content isn't shown in any search field within Confluence;

  • If the indexes are corrupted, the following log entries will appear in atlassian-confluence.log files:

    1 2 3 4 5 6 7 8 Caused by: org.springframework.dao.DataAccessResourceFailureException: Failed to read id for journal 'main_index': For input string: "<0x00><0x00><0x00><0x00><0x00>" ... Caused by: java.lang.NumberFormatException: For input string: "<0x00><0x00><0x00><0x00><0x00>" at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65) at java.lang.Long.parseLong(Long.java:578) at java.lang.Long.parseLong(Long.java:631) at com.atlassian.confluence.impl.journal.FilesystemJournalStateStore.getMostRecentId(FilesystemJournalStateStore.java:44) ... 277 more

Cause

The Confluence may be facing an indexing problem.

The most common reasons for indexing failure are described in Searching and Indexing Troubleshooting

Solution

  1. Clear any plugin cache

  2. Rebuild the indexes in Confluence. If necessary, rebuild it from scratch.

Updated on March 14, 2025

Still need help?

The Atlassian Community is here for you.