Office Connector Read Only Due to a Plugin Interfering with its Operation

Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When trying to edit an attachment (Excel, Word doc, etc) they are open in read-only mode. When editing the attachment Confluence logs the following stack trace:

1 2 3 4 5 Caused by: java.lang.NullPointerException at com.atlassian.confluence.pages.DefaultAttachmentManager.saveAttachment(DefaultAttachmentManager.java:78) at com.atlassian.confluence.extra.checkout.VersionedAttachmentManager.saveAttachment(VersionedAttachmentManager.java:45) <--- this is an entry from the Attachment Checkout plugin at com.atlassian.confluence.pages.DelegatorAttachmentManager.saveAttachment(DelegatorAttachmentManager.java:83) at sun.reflect.GeneratedMethodAccessor2675.invoke(Unknown Source)

Cause

Using the above stack trace as an example, the Attachment Checkout plugin by Locus-Global was responsible for interfering with the Office Connector operation. Specifically the version of the Attachment Checkout plugin used was an old version.

Resolution

If you encounter read only when editing a document attachment, check your atlassian-confluence.log file to see if there's an error logged. From the stack trace we may be able to learn more about the error. If the stack trace is related to another plugin like in the above, try to upgrade that plugin and check if that fixes the problem.

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.