Nothing appears in the atlassian-confluence.log file

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

No startup messages or content appear in the atlassian-confluence.log, usually during an upgrade attempt, restart, or other configuration change.

Diagnosis

Check the permissions on both the confluence-home and confluence-install directories. On a Linux system, use "ls -al".

Cause

Permissions are insufficient for the user who is running Confluence to write to the confluence-home directory.

Solution

Resolution

Apply the appropriate ownership or permissions to the Confluence home directory. Something similar to:

1 chown -R confluenceuser:confluenceuser confluence-home

ℹ️ substitute 'confluenceuser' with the name of the correct user, and 'confluence-home' with the name of your home directory.

Updated on April 2, 2025

Still need help?

The Atlassian Community is here for you.