Member of crowd-administrators Group Is Unable to See Administration Menu

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

A Crowd administrator that belongs to 'crowd-administrators' group is unable to see Administration menu (missing cog wheel icon on the header) when logging in to Crowd.

This happens right after creating an administrator group and mapping it to the application. There's a possibility that the 'System Administrator' checkbox is accidentally ticked off during the process.

Diagnosis

Diagnostic Steps

  • Run the following query in the database:

    1  select * from cwd_app_dir_group_mapping cadgm join cwd_granted_perm cgp on cadgm.app_dir_mapping_id = cgp.app_dir_mapping_id where cadgm.group_name = 'crowd-administrators';

    ... if the value of 'permission_id' is 1, then proceed with the resolution. Otherwise, please contact support@atlassian.com for assistance.

Cause

The System Administration flag is disabled for 'crowd-administrators' at Crowd application. At the same time, there's no other group with Admin right for Crowd application.

Solution

Resolution

Run the following query: (change the <group_mapping_id> to the 'group_mapping' value returned in the diagnosis stage)

1 update cwd_granted_perm set permission_id = 2 where app_dir_mapping_id = <ID of the 'app_dir_mapping_id' where permissions need to be overwritten>;

Updated on April 2, 2025

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