EOL Check Causes Health Check to Fail when a Proxy is Being Used
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
The instance health plugin adds a check for the presence of confluence-healthcheck-eol.json in <confluence-home-directory>/shared-home to check EOL date. If that file is not present on the system and the system cannot reach the marketplacet to check EOL the health check plugin will not run and will throw an error of 'there was an error performing the instance health check' in the GUI.
The following appears in the atlassian-confluence.log
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ERROR [SupportHealthCheckThread-8] [plugins.healthcheck.eol.EolSupportHealthCheck] check An error occurred when performing the EOL check, see the exceptions for more info
org.apache.http.conn.ConnectTimeoutException: Connect to marketplace.atlassian.com:443 [marketplace.atlassian.com/131.103.28.7] failed: Connection timed out
at org.apache.http.impl.conn.DefaultHttpClientConnectionOperator.connect(DefaultHttpClientConnectionOperator.java:149)
at org.apache.http.impl.conn.PoolingHttpClientConnectionManager.connect(PoolingHttpClientConnectionManager.java:353)
at org.apache.http.impl.execchain.MinimalClientExec.execute(MinimalClientExec.java:183)
at org.apache.http.impl.client.MinimalHttpClient.doExecute(MinimalHttpClient.java:107)
at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:82)
at org.apache.http.impl.client.CloseableHttpClient.execute(CloseableHttpClient.java:107)
at com.atlassian.confluence.plugins.healthcheck.util.SupportEolCheckUtil.makeRequestToMarketplace
Health Check Results :
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Name: End Of Life
Is healthy: false
Failure reason: TimeoutException after 20000ms
Severity: UNDEFINED
Diagnosis
Clearing the plugin cache doesn't help.
You're able to connect to marketplace, but the healthcheck still failed.
Cause
The issue also seems to be happening on environment that utilize outbound proxy, whereby, even configuration are done correctly (adding marketplace to the non proxy host config), and connection towards Marketplace is possible (add-ons and UPM works fine), the healthcheck plugin still throws
Connect to marketplace.atlassian.com:443 [marketplace.atlassian.com/131.103.28.7] failed: Connection timed out.
This bug was tracked on CONFSERVER-45506 EOL Check Causes Health Check to Fail when a proxy is being used.
Solution
Upgrade to Confluence version 6.0.3 or above.
Workaround
Create/Edit <CONFLUENCE_HOME>/shared-home/confluence-healthcheck-eol.json with the following content. This file is located in the /var/atlassian/application-data/shared-home folder by default on a linux system.
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{"versions":[{"name":"5.9","releaseDate":"2015-11-24"},{"name":"5.10","releaseDate":"2016-06-09"},{"name":"6.8","releaseDate":"2018-03-19"},{"name":"6.9","releaseDate":"2018-05-07"},{"name":"6.10","releaseDate":"2018-06-25"},{"name":"6.0","releaseDate":"2016-10-31"},{"name":"6.1","releaseDate":"2017-03-16"},{"name":"6.2","releaseDate":"2017-05-12"},{"name":"6.3","releaseDate":"2017-07-06"},{"name":"6.4","releaseDate":"2017-09-05"},{"name":"6.5","releaseDate":"2017-11-01"},{"name":"6.6","releaseDate":"2017-12-11"},{"name":"5.8","releaseDate":"2015-06-02"},{"name":"6.7","releaseDate":"2018-01-29"}]}
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