Confluence fails to start after upgrading with the automated installer

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Starting Confluence results in it stopping right away after upgrading using the installer. Nothing is written to the atlassian-confluence.log file.

Diagnosis

Inspecting the Tomcat logs (catalina files), we see the error:

1 2 3 4 5 6 7 8 9 10 09-Sep-2021 09:02:49.396 SEVERE [main] org.apache.catalina.startup.Catalina.start The required Server component failed to start so Tomcat is unable to start. org.apache.catalina.LifecycleException: A child container failed during start at org.apache.catalina.core.ContainerBase.startInternal(ContainerBase.java:928) ... Caused by: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Standalone].StandardHost[localhost].StandardContext[/${confluence.context.path}/synchrony-proxy]] ... Caused by: java.lang.IllegalArgumentException: More than one fragment with the name [spring_web] was found. This is not legal with relative ordering. See section 8.2.2 2c of the Servlet specification for details. Consider using absolute ordering. at org.apache.tomcat.util.descriptor.web.WebXml.orderWebFragments(WebXml.java:2257) at org.apache.catalina.startup.ContextConfig.webConfig(ContextConfig.java:1134) at org.apache.catalina.startup.ContextConfig.configureStart(ContextConfig.java:775)

Cause

A problem happened during the upgrade and the files on the installation folder were not replaced correctly, leading to corruption and the startup error above. This can happen if the installer was executed while the application was running.

Solution

  1. Ensure the Confluence process is stopped

  2. Run the installer again, making sure no errors are returned and it completes

  3. Check if Confluence can be started

If you still have problems, switch to the manual upgrade method instead of using the installer:

Updated on February 26, 2025

Still need help?

The Atlassian Community is here for you.