Cannot start Synchrony after installing Windows patches
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
The Synchrony process is killed, at random, usually after Confluence is running for a couple of days. As Confluence fails to restart the Synchrony process, Collaborative Editing stops working and the users can only edit pages after Collaborative Editing is disabled in the UI.
Synchrony can only be restarted by restarting Confluence.
Environment
7.1.1 - but can affect different Confluence versions after Synchrony was implemented (Confluence 6.0)
Windows Server
Diagnosis
Cannot enable Collaborative editing, as can be observed in the Synchrony logs:
<confluence-home>/logs/atlassian-synchrony.log
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[plugins.synchrony.bootstrap.DefaultSynchronyProcessManager] startup Starting Synchrony and enabling Collaborative Editing
2020-10-15 12:23:46,193 DEBUG [synchrony-interop-executor:thread-1] [plugins.synchrony.utils.SynchronyProcessUtil] killRunningSynchronyProcess Reading C:\atlassian\confluence_server\temp\synchrony.pid
2020-10-15 12:23:46,349 ERROR [Long running task: Restart Synchrony Task] [plugins.synchrony.tasks.AbstractConfigLongRunningTask] runInternal An error occurred when running a Synchrony ConfigLongRunningTask
-- url: /rest/synchrony-interop/restart | referer: https://<confluence-baseurl>/admin/confluence-collaborative-editor-plugin/configure.action | traceId: 8bde67de28b99aec | userName: xxx
org.zeroturnaround.exec.InvalidExitValueException: Unexpected exit value: 1, allowed exit values: [0], executed command [taskkill, /F, /PID, 3052]
at org.zeroturnaround.exec.InvalidExitUtil.checkExit(InvalidExitUtil.java:27)
at org.zeroturnaround.exec.WaitForProcess.call(WaitForProcess.java:114)
at org.zeroturnaround.exec.ProcessExecutor.executeNoTimeout(ProcessExecutor.java:938)
In Confluence Administration Synchrony process is showing an error:
Synchrony problems are preventing people from saving their work
To protect your team's shared drafts, we recommend changing to limited mode while you troubleshoot the problem.
In some cases, Synchrony logs will not log anything since the Windows Update.
Cause
This entry normally indicates that Windows was unable to kill the old Synchrony process and returned this error message.
Solution
Stop Confluence
Open the file <Confluence-Install>\temp\synchrony.pid and take note of this ID
Open the task manager and go to the Details tab
Ensure no process is running with the noted PID from step 2, if you see one, stop it
Delete the file <Confluence-Install>\temp\synchrony.pid
Start Confluence
Check if the Synchrony process is started and Collaborative Editing feature is working as expected.
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