Atlassian Companion app can't be opened in MacOS Catalina

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

This article applies to Confluence Server and Data Center 6.11 and later.

Problem

Confluence Server and Data Center users are unable to edit attached files using the Atlassian Companion app. Companion app fails to open with the following error:

"Atlassian Companion.app" can't be opened because Apple cannot check it for malicious software.

This software needs to be updated. Contact the developer for more information.

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Cause

Some versions of MacOS, such as 10.5 (Catalina), prevent you from opening any apps built after a specific date that have not been notarized by Apple. This is to protect you from malicious software.

Earlier versions of the Companion app were not yet notarized.

Possible Resolution

Upgrade Companion App to the latest version (currently 1.3.1).

Workaround

If you can't yet upgrade or the issue still persists after the upgrade, as a workaround, you can go to System Preferences > Security & Privacy > General. The Atlassian Companion app should be listed as blocked. Choose Open anyway.

See the "How to open an app that hasn’t been notarized or is from an unidentified developer" section of Safely open apps on your Mac in the Apple documentation for more information.

Updated on April 8, 2025

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