535 No SMTP server defined - while mail server is configured in Confluence

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

The following appears in the atlassian-confluence.log (or atlassian-confluence-outgoing-mail.log from 7.11)

1 javax.mail.AuthenticationFailedException: 535 No SMTP server defined. Use real server address instead of 127.0.0.1 in your account.

Diagnosis

While you have a mail server properly configured, still the above error message appears in the logs. It can happen that before an upgrade there were no problems, but when upgrading to another version of Confluence, suddenly the same settings won't work.

Cause

Anti-virus software is blocking connection to the mail server. We have experienced these symptoms with Avast antivirus, but the same problem may happen with different products.

Solution

Workaround

Disable the mail-related modules of your antivirus software, then re-enable them one-by-one to see which may be causing the issue.

Resolution

Disable antivirus software or configure it to exclude Confluence process and/or Tomcat from spam/mail protection.

Updated on April 2, 2025

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