Users are not receiving notifications for pull request activity after Bitbucket upgrade

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Following an upgrade of Bitbucket users are no longer receiving notifications by e-mail.

Environment

  • Bitbucket Data Center version 7.x

  • An SMTP server is configured in the instance

Diagnosis

You may see errors such as the one below in atlassian-bitbucket.log:

1 2 3 4 5 6 2021-10-07 08:10:11,442 ERROR [mail-sender:thread-1] bitbucket.mail-log Sending mail failed. Please verify the mail server configuration and check the logs for details; recipient: user@bitbucket.com; subject: TEST/test - Pull request #1: changing description org.springframework.mail.MailSendException: Mail server connection failed; nested exception is javax.mail.MessagingException: Could not convert socket to TLS; nested exception is: javax.net.ssl.SSLHandshakeException: The server selected protocol version TLS11 is not accepted by client preferences [TLS12, SSL20Hello]. Failed messages: javax.mail.MessagingException: Could not convert socket to TLS; Caused by: javax.mail.MessagingException: Could not convert socket to TLS

Cause

The configured SMTP server may be experiencing issues with regards to TLS protocols, as the logs keep logging the above errors. 

The server does not accept the protocol selected by the server (TLS 1.1). This parameter is described in the Configuration properties - Bitbucket Data Center and Server - mail.crypto.protocols.

Solution

In order to change which protocol(s) Bitbucket Server supports for sending e-mail, add the following property to<BitbucketHome>/shared/bitbucket.properties and then restart of Bitbucket Server instance. If you are. using Data Center, restart all nodes.

1 mail.crypto.protocols=TLSv1.2

Once this change has been made you should be able to see notifications being processed now that the emails are being sent to your SMTP server through the desired TLS protocol.

Updated on March 10, 2025

Still need help?

The Atlassian Community is here for you.