"Plan your upgrade" doesn't show latest Bitbucket versions

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

"Plan your upgrade" doesn't show the latest Bitbucket versions on the page. The "Upgrade to" selector is greyed out, unable to browse other Bitbucket releases.

Environment

Bitbucket Datacenter 7.19

This KB may be applicable to other Bitbucket-supported releases

Diagnosis

  • Verify if your Bitbucket application has access to the following URL https://puds.prod.atl-paas.net/rest/v1/upgrade/info.

    For the pre-upgrade planning tool to show the latest version data, your application needs to be able to access the URL. If a connection can’t be established, for example, if you’re using a restrictive firewall or proxy server settings, the tool won’t be able to fetch any updates to version data, supported platforms, or documentation.

  • Generate a HAR file while rendering the "Plan your upgrade" page. The API <BITBUCKET_BASE_URL>/rest/troubleshooting/latest/pre-upgrade/info couldn't retrieve release information and marks the attribute 'stale' to true in the API response.

Cause

The API response data is marked stale because the versions are fetched from the cached version list that is packaged with ATST (Atlassian Support Tools plugin). A possible block of all outbound connectivity from the instance could be the reason for causing the issue.

Solution

Review the outbound proxy configuration and allow the connectivity to https://puds.prod.atl-paas.net/rest/v1/upgrade/info

Updated on March 6, 2025

Still need help?

The Atlassian Community is here for you.