JIRA Source Tab Not Working

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

The Bitbucket Server JIRA issue column for commits has a link to the JIRA issue but the JIRA issue Source tab does not have any content.

The following warning can be seen in atlassian-bitbucket.log:

1 2012-10-28 16:28:08,796 WARN [TP-Processor12] 988x6635x1 192.168.10.70 "GET /rest/jira/1.0/issues/TST-12/commits HTTP/1.1" c.a.s.a.t.f.TrustedApplicationFilterAuthenticator Failed to login trusted application: jira:3790622 due to: com.atlassian.security.auth.trustedapps.InvalidCertificateException: Request not allowed from IP address: <Bitbucket Server_IP_Address>

Cause

The JIRA Trusted Application Incoming Authentication is set up with IP Patterns that do not include Bitbucket Server's IP address.

Resolution

There are three possible resolutions:

  1. Remove the setting for IP Patterns in JIRA Trusted Application Incoming Authentication.

  2. Configure the IP Patterns so that it includes Bitbucket Server's IP address.

  3. If JIRA and Bitbucket Server are both set up on separate servers then make sure both servers have the same time zone setting.

Updated on April 15, 2025

Still need help?

The Atlassian Community is here for you.