Error creating bean with name 'databaseSupplier'

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

Bitbucket Failed to start on the initial start after attempting upgrade

The following appears in the atlassian-bitbucket.log

1 2 3 4 5 6 7 8 9 Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'databaseSupplier': Invocation of init method failed; nested exception is com.atlassian.stash.internal.db.UnsupportedDatabaseException: The configured database is unsupported at org.springframework.beans.factory.annotation.InitDestroyAnnotationBeanPostProcessor.postProcessBeforeInitialization(InitDestroyAnnotationBeanPostProcessor.java:160) ... 5 common frames omitted Caused by: com.atlassian.stash.internal.db.UnsupportedDatabaseException: The configured database is unsupported at com.atlassian.stash.internal.db.DefaultDatabaseSupplier.validate(DefaultDatabaseSupplier.java:147) at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ... 5 common frames omitted

Diagnosis

Diagnostic Steps

Please confirm:

  • The type and version of the database

  • The version of git installed on the Bitbucket Server host machine

  • The exact steps taken during the upgrade process

  • Verify if a backup was taken of the instance prior to the upgrade

Cause

issues like this occur when the supported platforms are not updated with respect to the upgrade.

Solution

Resolution

The issue is generally resolved by pointing to the correct version of Database.

Updated on April 2, 2025

Still need help?

The Atlassian Community is here for you.