Bitbucket URL is not accessible while accessing through Browser
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Bitbucket Data Center URL is not accessible through the browser after restoring the backup from the existing environment to the new server. The browser shows:
"Can't reach this page, too long to respond."
"Can't establish a connection to the server."
Environment
Bitbucket Server 6.3.1
Diagnosis
Verify the following points at the Bitbucket end:
Verify whether the process of Bitbucket is present on the Bitbucket which indicates Bitbucket is up and running.
To do the same on the Linux server use -> ps -ef | grep bitbucket
For the Windows Server, check the Bitbucket process in the Task Manager.
Verify the following points at Browser machine or client machine:
ping on <Bitbucket_Server_Host>
1 2 3 4
Example: ping bitbucket_host PING localhost (10.132.122.16): 56 data bytes 64 bytes from 10.132.122.16: icmp_seq=0 ttl=64 time=0.051 ms 64 bytes from 10.132.122.16: icmp_seq=1 ttl=64 time=0.089 ms
telnet on <Bitbucket_Server_Host> <Port>
1 2 3 4
Example: telnet bitbucket_host 7990 Trying 127.0.0.1... Connected to localhost. Escape character is '^]'.
tracert on <Bitbucket_Server_Host>
1 2 3 4 5 6 7 8 9
Example: tracert bitbucket_host traceroute to bitbucket_host (10.132.122.16), 64 hops max, 52 byte packets 1 localhost (127.0.0.1) 0.415 ms 0.058 ms 0.065 ms 2 xyzhost (198.0.1.2) 0.214 ms 0.044 ms 0.056 ms 3 abchost (198.0.1.2) 0.214 ms 0.044 ms 0.056 ms 4 bitbucket_host (10.132.124.18) 0.214 ms 0.044 ms 0.056 ms Note: This gives us an idea if request reaches to the actual Endpoint server (Bitbucket Server). And if it is getting diverted to some other server. It result is not correct, output provides clue for possible IPtables service is not configured correctly. Example: If you see the last entry in the above output, it points to bitbucket_host (10.132.124.18) though actual server address is 10.132.122.16 which indicates that servers route are not configured correctly.
curl command over <Bitbucket_Server_URL>
1 2 3 4 5 6 7 8
curl -u username:password http://localhost:7990/ -v (Here replace username and password with Bitbucket username and password) * Trying 127.0.0.1:7990... * Connected to localhost (127.0.0.1) port 7990 (#0) * Server auth using Basic with user 'xyz' > GET / HTTP/1.1 > Host: localhost:7990 Note: curl command provide us the details whether Bitbucket Server is accessible outside.
Cause
Configuration of IPtables service at Bitbucket level is incorrect which might be the cause of this issue.
Note: IPtables is a user-space utility program that allows a system administrator to configure the IP packet filter rules of the Linux kernel firewall, implemented as different Netfilter modules. The filters are organized in different tables, which contain chains of rules for how to treat network traffic packets.
Solution
Make sure that the communication is open between the client machine and the server.
Make sure the IPtables or IPtables service configure correctly.
Was this helpful?