Pipeline build failed with no space left on device error
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
How to fix the failed Pipeline build with no space left on device error
Platform: Bitbucket Pipeline Self-hosted Runners - All
Solution
Possible causes:
The
/tmp
directory lacks sufficient disk space.
Troubleshooting Steps:
Verify the
/tmp
DirectoryIt is essential to confirm that the
/tmp
directory, where the Runner is configured, has adequate disk space available.The temporary directory is established during the Runner setup. The directory is specified using the following variables based on the type of Runner:
For Linux Docker Runners -
WORKING_DIRECTORY
For Other Runners -
workingDirectory
To assess the available disk space in the directory:
For Windows Shell Runner, refer to Microsoft's article Find out how much storage your PC has.
For Other Runners: Execute the following command in the terminal of the host machine to check the available space for each mounted drive and verify if the Runner's working directory (/tmp by default, unless altered during the Runner start) is nearing its limit and how much disk space is allocated to it:
1
$ df -h <working directory>
Free Up Space
To free up disk space allocated as the Runner's working directory, consider deleting unnecessary and large files, relocating some files to another disk or storage solution, or increasing the disk size.
Alternatively, the Runner's working directory can be changed to a different folder where the host has more disk space available:
Linux Docker Runner: Changing the working directory of your runner | Linux Docker runner.
Other Runners: Update the --working-directory argument in the Runner start command:
1
$ ./start.sh <rest of arguments> --workingDirectory <full path to desired working directory folder>
Was this helpful?