No avatar and name showing on Bitbucket Cloud Pipelines home page
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
This article explains why Bitbucket Cloud Pipelines may not show an avatar for specific Pipelines builds, and provides a solution for resolving this problem.
Environment
Bitbucket Cloud Pipelines
Diagnosis
Your previous commit(s) show your avatar and name correctly, but for some reason, you're now seeing no avatar and name details on your repository Pipelines build list:
However, when you go to your repository Commits tab, the commit's author and name show correctly.
When you check the specific Pipelines build via API using the API endpoint below, you'll notice that it only shows the type and UUID fields but not the display name and avatar fields.
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curl -u bb_username:app_password "https://api.bitbucket.org/2.0/repositories/workspace_id/repo_name/pipelines/"
Example result:
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"creator" : {
"type" : "user",
"uuid" : "{12345def-ghi1-23abc-de12-345fgh123345}"
},
Cause
This is likely caused by pushing using the SSH protocol, where the SSH key that is used has been added to your team workspace.
Unfortunately, Bitbucket Cloud Pipelines does not recognise the creator of a team workspace because it is not tied or associated to a specific Bitbucket Cloud account.
Solution
To resolve this, you will need to move the public SSH key from your team workspace to your Bitbucket Cloud account's level SSH key by following the steps below:
Go to your team workspace - https://bitbucket.org/workspace_id
Click the settings icon on the top right
Click Workspace settings
Click SSH keys (Under Security)
Find your specific SSH key
Click the Edit icon and copy the SSH key
Go to your personal settings - https://bitbucket.org/account/settings/
Click SSH keys
Click Add key
Enter a Label and paste your SSH key there
Lastly, click Add key
After this, your new Bitbucket Cloud Pipelines builds should show your avatar and name correctly on the Pipelines home page.
If the above instructions do not assist in resolving the issue, please raise a support ticket or raise a community support ticket for further assistance with this.
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