Merge button is not visible on Bitbucket Cloud pull request
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
The purpose of this article is to explain why the merge button may not be present on a pull request and to provide steps to troubleshoot/resolve the issue
Environment
Bitbucket Cloud repository
Diagnosis
You access a pull request that needs to be merged
When attempting to merge the pull request, no merge button is visible and therefore it is not possible to merge the pull request
Other users on your team may or may not be able to access the merge button depending on their settings (see below)
Cause
If branch restrictions exist for the branch that is being merged into, this will prevent you from seeing the merge button entirely if you have not been granted the access necessary to merge a pull request
Solution
NOTE
You must be an administrator to perform the steps below, if you don't have the necessary access - please reach out to a workspace administrator to follow the steps below.
Access branch restrictions settings on the repository by navigating to Repository Settings > Branch Restrictions
Check the settings for the branch on this page - if the user encountering the issue is not present in the Merge via Pull Requests access type (or if None are present), this will prevent this user from being able to merge
Click the Edit button (shown above), add the necessary users to the Merge via Pull Requests access type by entering either the individual user/user group and click Save when finished
Check the pull request again, the Merge button should now be visible and you should be able to complete the merge process as normal
NOTE:
We have existing documentation to use branch permissions that explains branch restrictions in full, please consult this article for further information.
If you are encountering issues following this documentation - please raise a support ticket or a community support ticket for further assistance.
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