Jira Issue keys do not show on Pull Request Jira tab

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

We might see a problem where a Jira issue key is not present in the Jira tab despite being linked to the Pull Request.

Diagnosis

Jira issues in Pull Requests may not be picked up to be placed in the Jira tab for multiple reasons -

  • If the link between the Jira site and Bitbucket is not done correctly

  • The Pull Request did not have the issue key at the creation time. Instead, it was added later on by editing the Pull Request

  • The Issue Key is only added to the Pull Request description or comments. In other words, the Issue key is not present in the Pull Request title, commits, or the branch name.

Cause

When a Pull Request is being created, the Jira issue must be present within any of the following components of the Pull Request -

  • The commits associated with the Pull Request must have the Issue key in the commit message.

  • OR the Pull Request title must contain the Issue key

If the Issue key is only added to the Pull Request description or the comments of the Pull Request, the webhook to add the Jira issue to the Jira panel in the Pull Request will not be triggered.

Secondly, the same webhook is only configured to trigger at the time of the creation of the Pull Request. If the Pull request is created without the Jira issue key and the Pull Request is later edited to include the Issue key, It is expected that the Jira issues not be picked up and added to the Jira panel.

Solution

If the Pull Request is already created without the issue key in the commits or the title, you must decline the Pull Request and create a new one with the Issue key present this time. As mentioned above, the Issue key is only picked up if the key is present at the creation time.

Updated on February 25, 2025

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