How to set a password for the Bitbucket Account created via SSO

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

To create an account on Bitbucket, you must provide a valid email address and a password. Another alternative is to use authentication via Single sign-on (SSO), where Bitbucket will use the authentication of another service/application, such as Google or Microsoft, to create the account. In this case, it is not necessary to enter a password for your Bitbucket Account.

(Auto-migrated image: description temporarily unavailable)

However, there may be a need to use an email and password to authenticate in applications.

Environment

Bitbucket Cloud

Diagnosis

When trying to log in to Bitbucket using the email and password of the application/service (Google, Microsoft, etc.) used to create the account, the error "Incorrect email address and/or password. Do you need help logging in?" occurs.

Cause

This issue occurs because an access password was not defined for the Bitbucket account, which is authenticated via SSO through an application/service.

Solution

In order to set a password for the Bitbucket account, follow the steps below:

  • Go to https://bitbucket.org/account/password/reset/

  • Add the Bitbucket account email

  • An email to set a password will be sent to the previously added email address. Access the link in the email and add a password for your account

  • After following these steps, a password has been set for the Bitbucket account. It is possible to login to Bitbucket using the defined email and password

Updated on March 3, 2025

Still need help?

The Atlassian Community is here for you.